Mac OS X Font Problems - Helvetica, Leopard and PostScript

Ben Greiner -

Helvetica - 10.5 Leopard and 10.6 Snow Leopard

If you use Helvetica and Helvetica Neue (most designers do) and you plan to run Mac OS X 10.5 Leopard or greater then you really need the OpenType versions of these fonts (included with Adobe Font Folio 11). Pricing for standalone versions of these fonts is below and more information on this issue can be found here.

Old PostScript Fonts

Some older PostScript fonts may no longer work with Snow Leopard. We do know old PostScript HTF (Hoeffler Type Foundry) fonts do NOT work. Bitstream fonts created between 1987 and 1990 also do NOT work. There may be others as well. We highly recommend using OpenType fonts with Snow Leopard.

Related font problems and fixes:

 

Please contact us if you have any questions or need assistance.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk